0
I Use This!
Inactive

Commits : Listings

Analyzed about 20 hours ago. based on code collected about 22 hours ago.
May 07, 2023 — May 07, 2024
Commit Message Contributor Files Modified Lines Added Lines Removed Code Location Date
copyright update More... over 13 years ago
handle 1 bit bitmaps with transparency More... over 13 years ago
ppmquant location More... over 16 years ago
another LE32 fix More... about 17 years ago
LE32 fix More... about 17 years ago
win compile More... about 17 years ago
Add notes about string concatenation, HEX + -H considerations, "UL" vs "LU". Also fix markup typo.
John Marshall
as jmarshall
More... over 18 years ago
Unify .s and .ss strings: string concatenation is now available everywhere. Document concatenation via both "+" and "\".
John Marshall
as jmarshall
More... over 18 years ago
Fixed markup typos, as detected by the W3C validator (and added an HTML 4.01 Transitional doctype). The only remaining complaint from the validator is about our nasty habit of using <ul>...</ul> (without any intervening <li> tags) as a substitute for indentation.
John Marshall
as jmarshall
More... over 18 years ago
ParseNavigationList() and ParseNavigationMap() are given a p_int, not plain int. Where p_int is larger than int (e.g. AMD64), this was previously not entirely initialising RCNAVIGATION.numOfObjects, leading to a crash exhibited by e.g. the fnav_test.rcp sample.
John Marshall
as jmarshall
More... over 18 years ago
Use the half-arsed vaguely right <stdint.h>-style typedefs throughout these structs; in particular, use PILRC_ULONG rather than plain "long", as the latter is wrong on 64-bit platforms. The change in signedness is harmless -- bi[XY]PelsPerMeter are unused, and the only usages of bi{Width,Height} are in fact to pass them to a function expecting an unsigned.
John Marshall
as jmarshall
More... over 18 years ago
Remember to use p_int (not just int) in a struct that's going to be given to CbEmitStruct(). [Fix #1 for 1244602; thanks to Lucas Wall]
John Marshall
as jmarshall
More... over 18 years ago
Don't process #defines (in .rcp files) when they are in text that is being skipped due to #ifdefs.
John Marshall
as jmarshall
More... about 19 years ago
Diagnostic() should treat POSITION->szFilename==NULL as a non-localised diagnostic as well. Also print "pilrc: " (and perhaps "warning: ") in front of such diagnostics.
John Marshall
as jmarshall
More... about 19 years ago
Some time ago I made Usage() follow the GNU Coding Standards for usage displays w.r.t. printing to stdout and returning EXIT_SUCCESS. However Usage() is really misnamed -- it is mostly used to exit in the case of command line option processing errors, and in this case returning EXIT_SUCCESS is a bug.
John Marshall
as jmarshall
More... about 19 years ago
Add proper implementations of FIsString() and PchGetString(). These allow concatenation involving both simple string tokens and string-valued #defines, and go to some effort to provide useful error messages.
John Marshall
as jmarshall
More... about 19 years ago
Update copyright year (as printed) to 2005.
John Marshall
as jmarshall
More... about 19 years ago
The non-trivial changes to the various parsers so that they use the new FIsString() and PchGetString() string parser functions.
John Marshall
as jmarshall
More... about 19 years ago
Move UngetTok()'s token buffer into INPUTCONTEXT. When you open a new input stream, any ungotten tokens from the previous stream should not appear immediately, but rather after the new input stream has run out and input has reverted to the previous stream.
John Marshall
as jmarshall
More... about 19 years ago
Initialise the lexer in OpenInputFile(), i.e., each time a new input stream is opened.
John Marshall
as jmarshall
More... about 19 years ago
FIsString() and PchGetString() are new functions encapsulating string parsing. A later checkin will provide proper implementations and remove the old PchGetSz/PchGetSzMultiLine functions. This checkin simply provides dummy versions and the trivial renaming parts of the changes needed to use them.
John Marshall
as jmarshall
More... about 19 years ago
* Use DesirableLocale() instead of ad hoc szLocaleP checking. * Where practical, move locale tests to after we've finished parsing, so that a buggy string skipping early return is not needed.
John Marshall
as jmarshall
More... about 19 years ago
Rename FPeekTok() to PeekTok() -- "F" is inappropriate because this function doesn't return a boolean flag.
John Marshall
as jmarshall
More... about 19 years ago
Check DesirableLocale() only *after* all parsing is complete. Otherwise if the object is not to be emitted then parts of its source code will be left behind in the input stream, causing spurious syntax errors.
John Marshall
as jmarshall
More... about 19 years ago
Open and close the .ro temporary file before we start appending resource data to it, so that it exists even if there are no resources to be added to it. (This is to be sure an unusual situation that is probably erroneous in itself, but "<tempfile> not found" is not a very friendly way to diagnose it.)
John Marshall
as jmarshall
More... about 19 years ago
Exterminate ObjectDesiredInOutputLocale() in favour of the more flexible and comprehensible DesirableLocale().
John Marshall
as jmarshall
More... about 19 years ago
Fix bug in DesirableLocale(): If no -Loc option has been given, then objects with locales should NOT be emitted. Particularly: if you have localised versions of the same form for several locales, you don't want to emit all of them!
John Marshall
as jmarshall
More... about 19 years ago
According to PalmSource's FileFormats.pdf (p7), the database name must be NUL-terminated within its 32 bytes and is thus a C string of maximum length 31, rather than a 32 character fixed-length string to be manipulated with strncpy()/strncat()/etc.
John Marshall
as jmarshall
More... about 19 years ago
Update copyright date; this code changed on 2005-01-19.
John Marshall
as jmarshall
More... about 19 years ago
Split out INPUTCONTEXT members relating to the file itself into a new FILELINE structure. Diagnostic() now takes a FILELINE rather than just filename & lineno, thus providing everything needed by the CW plugin.
John Marshall
as jmarshall
More... over 19 years ago